هام جدآ للمبتدئين فى ربط الفيجوال بالأوتوكاد

إنضم
18 سبتمبر 2013
المشاركات
105
مجموع الإعجابات
3
النقاط
18
هذا البرنامج المرفق هام جدآ للمبتدئين فى ربط الفيجوال بيزك6 بالأوتوكاد
وهو عبارة عن تجميع لبعض الأكواد من مواضيع المنتدى ومن اجابات الأعضاء عن أسئلتى

ملحوظة هامة:-

لن يستفيد من هذا البرنامج الا من يتقن الفيجوال بيزك6 اتقانآ جيدآ ولكنه مبتدئ فقط فى ربطها بالأوتوكاد

قبل تشغيل المشروع (قبل عمل ال
RUN) يجب عمل الخطوات الآتية

1-من قائمة Project نختار References ، ثم يجب اختيار الأوتوكاد المطابق لنفس الإصدارالمرتبط بالنسخة المحملة على جهازك (2000-2004-2007-2009....)
(فى برنامجى المرفق كانت
Autocad 2007 Type Libraryفيجب عليك تعديلها حسب النسخة المحملة على جهازك)

2- ان كانت نسخة الأوتوكاد المحملة على جهازك 2004 أوقبل ذلك فابحث فى كود البرنامج المرفق(FIND current project) عن
العبارة "AutoCAD.Application.17" وعدلها الى "AutoCAD.Application.16"
وان كانت نسخة الأوتوكاد المحملة على جهازك
2007 أو 2008أو 2009 فاتركها كما هى "AutoCAD.Application.17"
وان كانت
2010 أو 2011 فعدلها الى "AutoCAD.Application.18"
وان كانت
2012 أو 2013 أو 2014 فعدلها الى "AutoCAD.Application.19"

3-فى كود ال(Form_Load) عدل الجملة الآتية حسب اسم الملف ومساره عندك
PHP:
DRAWNAME = "E:\برامج الرسم\فورم للمنتدى\DRAWING1"
 

مواضيع مماثلة

egyptsystem

عضو جديد
إنضم
6 ديسمبر 2013
المشاركات
8,366
مجموع الإعجابات
563
النقاط
0
جزاكم الله عنا كل خير
 
إنضم
18 سبتمبر 2013
المشاركات
105
مجموع الإعجابات
3
النقاط
18
لن يستفيد من هذا البرنامج الا من يتقن الفيجوال بيزك6 اتقانآ جيدآ ولكنه مبتدئ فقط فى ربطها بالأوتوكاد
من لم يتقن الفيجوال بيزك6 اتقانآ جيدآ فعليه بهذا الموضوع

تعلم التحكم ببرنامج أتوكاد من خلال فجوال بيزك واصنع برنامجك الخاص خطوة بخطوة
http://www.arab-eng.org/vb/showthread.php?t=183433
 
إنضم
18 سبتمبر 2013
المشاركات
105
مجموع الإعجابات
3
النقاط
18
2- ان كانت نسخة الأوتوكاد المحملة على جهازك 2004 أوقبل ذلك فابحث فى كود البرنامج المرفق(FIND current project) عن
العبارة "AutoCAD.Application.17" وعدلها الى "AutoCAD.Application.16"
وان كانت نسخة الأوتوكاد المحملة على جهازك
2007 أو 2008أو 2009 فاتركها كما هى "AutoCAD.Application.17"
وان كانت
2010 أو 2011 فعدلها الى "AutoCAD.Application.18"
وان كانت
2012 أو 2013 أو 2014 فعدلها الى "AutoCAD.Application.19"
طبعآ من يتقن الفيجوال بيزك6
يمكنه استبدال هذه الجملة بكود بسيط بحيث يصلح هذا البرنامج مع أى نسخة أوتوكاد
 
أعلى